New Call-to-action

Sign In/Register

Waxie will discontinue support for the TLS 1.0 protocol on:

January 15, 2018

This is mandated by the Payment Card Industry (PCI) Security Standards Council. After this date you must access our website using a browser that supports TLS 1.1, TLS 1.2, or above, which includes Internet Explorer 11, Google Chrome, or Mozilla Firefox. Please contact your Information Technology (IT) department to ensure you are using a compatible web browser.